The screen keeps showing Connecting

From Haasonline Software Wiki
Jump to: navigation, search

The screen keeps showing on "Connecting..."

First thing to try

This can be a very simple refreshing issue. If true then it can be solved by:

  • Try to press F5 to refresh the page.
  • Try to press CTRL and F5 together to force a refresh and clean cache.

If the refresh did not work then it is likely to assume an interface hosting problem. If this is true then the terminal view will show a line in yellow, or red, with a related message.

The terminal is only shown on the Windows operating system. On OSX and Linux a log files are created and stored into the ../HTS/Log directory.

Second thing to try

HTS requires 2 hosting ports. By default port 8090 is used for hosting the HTML interface and port 8092 is used for hosting a WebSocket to make the interface interactive.

We can already confirm port 8090 is working if you see the interface saying "Connecting..." so this hosting issue is very likely to be related to port 8092.

To solve this we need to explore some technical things. It will look a bit complex but it is really easy.

  • Please go to the "My Documents" folder ("libraries" folder on Linux and OSX)
  • You will see a folder called "HTS".
  • Inside the "HTS" folder is another folder titled "Settings". Navigate to this folder to view its contents.
  • You should see a file called "MainSettings.XML".
  • Open "MainSettings.XML" with a text editor like Notepad or Write.
  • In the file there is a row saying "HubPort" with the defined port number of "8092".
  • Simply change the default value of 8092 to 8088 and save the file again.
  • Start HTS and now it should be able to connect properly.

On OSX and Linux it might be possible this solution is not working. Please contact the support desk in case this applies to you.