The screen keeps showing Connecting

From Haasonline Software Wiki
Jump to: navigation, search

The screen keeps showing on "Connecting..."

First thing to try

This can be a very simple refreshing issue. If true then it can be solved by:

  • Try to press F5 to refresh the page.
  • Try to press CTRL and F5 together to force a refresh and clean cache.


If the refresh did not work then it is likely to assume an interface hosting problem. If this is true then the terminal view will show a line in yellow, or red, with a related message.

The terminal is only shown on the Windows operating system. On OSX and Linux a log files are created and stored into the ../HTS/Log directory.

Second thing to try

HTS requires 2 hosting ports. By default port 8090 is used for hosting the HTML interface and port 8092 is used for hosting a WebSocket to make the interface interactive.


We can already confirm port 8090 is working if you see the interface saying "Connecting..." so this hosting issue is very likely to be related to port 8092.

To solve this we need to explore some technical things. It will look a bit complex but it is really easy.

You will need to edit the <HubPort> from 8092 to 8088. Save the file once you are done. If port 8088 still doesn't work, you can try 8060 as well.

You can find the file in:

  • Windows it is in My Documents\HTS\Settings
  • OSX users it is in ~/Library/Application Support/HTS/Settings/
  • Linux it is in root/HTS/Settings


On OSX and Linux it might be possible this solution is not working. Please contact the Support Desk if it doesn't work.